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1.0 INTRODUCTION 
 

OPN_SLM is a simple to use barcode-based system for attendance monitoring/ event logging and for 
monitoring time spent performing activities. OPN-SLM monitors: 
 

• Attendance at individual Sites/ Locations 
• Time spent at individual Sites/ Locations 
• Overall time taken visiting multiple Sites/ Locations (with confirmation of attendance and/or 

time spent at the associated individual Sites/ Locations) 
 

The system is based on the OPN2001 barcode data collector. These compact units will be used to 
scan barcoded lcodes as the activity being monitored is performed. The scanned codes will be date/ 
time tagged by the data collector and stored in internal memory for downloading into the system                
database and subsequent reporting and analysis. 
 

A utility is also available for remote field staff to allow the OPN2001 data collectors to be downloaded 
to a simple data file which can be forwarded to head office for importing into the OPN_SLM                        
database.  



2.0 INSTALLATION  
 

OPN_SLM will normally be supplied on CD, or sent electronically.  
 
Alternatively an evaluation copy of OPN_SLM may be downloaded from the ERS website at http://
www.ers-online.co.uk/o5143/opn-slm-ers-service-level-monitoring-software-solution. In this case 
download both the Demo OPN_SLM and the DEMO OPN_SLM Reports from the webpage. 
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To install from CD or electronic delivery: 
 
1) Run the OPN_SLM installer setup.exe 

from the system CD or electronic 
download and follow the prompts. 

  
2) Run CRRedist2005_x86.exe to install 
 the components used by the reporting 
 module. 
 

Now proceed to Section 2.1 below to install the 
drivers for the OPN2001 data collectors  

To install an evaluation copy downloaded from 
ERS website: 
 
1) Run the OPN_SLM installer 

OPN.SLM.msi and follow the prompts. 
  
2) Run CRRedist2005_x86.exe to install 
 the components used by the reporting 
 module. 
 

Now proceed to Section 2.2 below to start us-
ing the software 

2.1 INSTALLING THE OPN2001 DRIVERS 
These drivers are used by OPN_SLM when downloading the OPN2001 data collectors. 
To install the drivers run the Opticon Driver Installer (USB Drivers Installer.exe) from the system CD 
of electronic delivery and proceed as shown below.  

1) Click Run 

2) Click OK  

3) Click OK  

4) Click OK  

5) Click OK. 
The OPN drivers are now installed  

Note: Do not connect the OPN2001 data collector onto the PC until the drivers have been installed. 
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2.1.1 CHECKING THE DRIVER INSTALLATION 
The driver installations can be checked via the Windows Hardware Device Manager as follows: 

Connect the scanner to the PC and from the Windows Device 
Manager expand the Ports section. The scanner will be listed 
with a description similar to: 
 

Opticon USB Code Reader (COMxx) 

The Windows Device Manager may be accessed by 
right-clicking My Computer then selecting Properties 
from the drop down menu. 
Go to the Hardware Tab and click Device Manager 

2. Click Create Database 

3. Specify a location and name for the database file and click 
Save.  The default location for the database is: 
C:\ProgramData\Electronic Reading Systems Ltd\OPN_SLM 

4. The database has been successfully 
created. Click OK to continue. 

5. Click Yes to make this the active database 

1. Click Tools > Options from 
the program menu bar  

2.2  CREATING THE SYSTEM DATABASE 
Once installed run OPN_SLM and create the system database as shown below: 
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2.3 LICENCING OPN_SLM 
After initial installation the software will run in demonstration/evaluation mode where the max.                  
number of records in the database will be limited. 
 

To licence the software for normal use click Help > Licence Management and proceed as follows: 

1. Click Change Licence 

2. OPN_SLM generates a random Keycode. 
Contact ERS for the relevant release code  
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3.0 CONFIGURING OPN_SLM 
OPN_SLM includes a number of databases which may be configured as required depending on the 
specific activity monitoring requirements: 
 

• Operator Database. Configuring the operator database allows the individual operators per-
forming the activities are to be logged. Operators can simply logon to the data collectors using 
a barcoded Operator ID. As an alternative the data collectors can be allocated to individual 
operators if required.  

 Configuring the operator database is optional, and is not required if logging the individual           
 operators is not required 
• Locations Database. This database contains details of the Locations being monitored. Data 

fields include: Location Code (barcode), Location description + 4 additional data fields which 
can be freely allocated by the user. 

• Routes Database. One or more Routes may be configured, each comprising a list of locations 
expected to be visited whilst performing specific activities. Each configured Route includes a 
Route Code and Description together with a list of the Location Codes to be included in that 
Route. 

 Configuring the Routes database is optional, however since the use of Routes allows identi-
 fication of any Locations which have been missed when performing activities it is expected that 
 this wi ll be used in the majority of cases.   
• Status Codes Database. A database of status codes may be maintained providing a range of 

status codes or ‘observations’ which may be logged whilst performing the activity at different 
locations by scanning the relevant barcoded Status Code. Each Status comprises a Status 
Code (barcode) and description. 

 Configuring the Status codes database is optional, and is not required if status code monitor-
 ing or ‘observation’ logging is not required.  
 

These databases may be configured may be maintained manually via the PC keyboard (see section 
3.1 below) or by importing simple csv text files containing relevant data (see section 3.2 below).   
 
Note: OPN_SLM also contains a Transactions database which is used to hold the activity monitored 
data. This database is described in section 6.1 below and is not described further here. 
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3.1 MANUALLY MAINTAINING THE SYSTEM DATABASES 
To manually maintain the system databases proceed as below: 

1. Click Edit from the program menu bar and select 
the relevant database from the displayed menu. 

2. To add a new record click Add New and proceed to enter the relevant details as below 
and click OK to save. 
 

To edit an existing record click to highlight the record and click Edit. Amend the displayed 
details and click OK  
 

To delete one or more records highlight the relevant records and click Delete 

Locations Database includes Location code, description 
and 4 additional fields which can be freely used.  
The titles for the additional fields can be configured (see 
section 2.1.1 below 

Routes Database allows individual Locations to be grouped 
into Routes for reporting. Note: a Location can be used in 
multiple Routes if required. 

Operators Database. Includes details of operators; use if tracking individ-
ual operators using the data collectors. 
Operators may logon to the data collector by scanning their barcoded Op-
erator ID. Alternatively data collectors may be allocated to the operators by 
including the serial no. of the allocated unit in the operator’s record. 

Status Codes Database. Includes Status code  (barcode)  
and description. 
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3.2 IMPORTING DATA INTO THE SYSTEM DATABASE 
The system databases may also be initialised by importing details from a simple text file. 
 

To import operator details click File > Import > Operator/ Serial No. Link File from the program 
menu bar and proceed as follows: 

1. Click File >  Import from the program menu 
bar and select the relevant datafile to be imported 

2. Browse to the relevant import file and click Open to import. 
 

NOTE: The imported data will overwrite existing operator data 

The format of the iinput data files is detailed in Appendix A below 

3.1.1 CONFIGURING THE ADDITONAL FIELD NAMES FOR LOCATIONS 
To configure the additional field names click Tools > Options from the program menu bar and select 
the Additional Fields Tab: 

2. Enter the relevant field names into the boxes provided and click OK when finished. 
 

These field names will then be used for display and reporting purposes. 

1. Click Tools > Options from the program menu bar 
and select the Additional Fields Tab 
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4.1 LOGGING ON TO THE DATA COLLECTORS 
If required operators can logon to the data collectors by scanning an Operator ID barcode. This will 
automatically tag the operator ID to the transactions enabling the operator performing the activity to 
be tracked. 
 

4.1.1 DATA FORMAT FOR THE LOGON BARCODES 
In order for the data collector to recognise the barcode as an operator ‘logon’ the barcode must be 
created using the relevant Operator ID as configured in the Operators database with a leading dot 
character. 
 

Thus a logon barcode for operator ID 1001 would contain the data ‘.1001’. For example: 

OPERATOR 1001 

4.2 SIMPLE ATTENDANCE SCANNING 
In this case the OPN2001 will be used to scan barcoded Location Codes to confirm attendance at the 
locations by the operator.  
 

4.2.1 DATA FORMAT FOR THE LOCATION BARCODES 
The scanned location barcodes will simply be the relevant Location Codes from the Locations data-
base printed in barcode format. 

Note: The leading dot character will identify this as a logon 
barcode and will automatically be stripped before storing 
the data into the transactions database 

LOCATION LOC001 

Thus the barcode representing Location Code LOC001 would simple contain the data ‘LOC001’, for 
example: 

4.0 USING OPN_SLM 
 

OPN_SLM may be used to monitor a number of activities including: 
 

• Simple Attendance Logging. In this scenario operators scan simple barcoded location codes 
when attending different locations. The Locations may be grouped into ‘Routes’ in order to re-
port both on the Locations visited, and those which were missed. 

• Time Spent at Individual Locations. Barcoded location codes can be created to allow opera-
tors to ‘Clock on’ when arriving at a Location and to ’Clock off’ when leaving. In this way 
OPN_SLM can monitor not only the Locations that have been visited, but also the time spent 
at each location. 

• Time Spent across Multiple Locations. Even if not tracking the time sent at individual loca-
tions, as above, barcodes can be created to allow the operator to track the overall time spent 
performing an activity across multiple locations. In this case the operator will scan a ’Group 
Start’ barcode when starting the activity and scan the associated ‘Group Stop’ barcode when 
finishing the activity.  

• Attendance Logging with Status Monitoring. One or more Status Codes may be scanned at 
any location if required to log an ‘observation’ or status relevant to that Location. Status Code 
monitoring can be used with any of the scenarios above. 
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4.4 LOGGGING STATUS CODES AT LOCATIONS 
One or more Status codes or ‘observations’ may be logged at any location by scanning a suitable 
Status Code barcode. Where Status codes are to be attached to a Location these will be scanned 
after the operator has scanned the Location code to confirm attendance. (ie: Scanned Status Codes 
apply to the current ‘active’ location in the data collector). 
 
4.4.1 DATA FORMAT FOR STATUS CODE BARCODES 
In order for the system to recognise the barcode as a Status Code the barcode must be created us-
ing the relevant Status code as configured in the Status codes database with a leading % character. 
 

Thus a barcode for Status Code ERS021 would contain the data ‘%ERS021’. For example: 

STATUS ERS021 

4.3 MONITORING TIME SPENT AT INDIVIDUAL LOCATIONS 
In this case the operator scans a ‘Start Location’ barcode on arrival at the location and a separate 
‘Finish Location’ barcode on departure allowing both the operator’s attendance at the Location to be 
confirmed and detailing the duration of the visit. 
 

4.3.1 DATA FORMATS FOR START LOCATION AND FINISH LOCATION BARCODES 
The barcodes used for Start Location and Finish Location will contain the relevant Location Code 
from the Locations database. OPN_SLM provides 2 formats for the Start Location and 2 formats for 
the Finish Location barcodes as follows: 

START LOCATION LOC001 

LOCATION LOC001 

START LOCATION BARCODES 
The Start Location barcode can be the ‘Standard’  
Location barcode as used above for simple atten-
dance scanning, or can be the Location Code with a 
leading + character. 
Either of these formats will be interpreted as a START 
LOCATION ‘instruction’ 

FINISH LOCATION BARCODES 
The Finish Location barcode can be the Location 
Code with a leading - character, or the generic              
barcode ‘–FINISH’ 
Either of these formats will be interpreted as a                
FINISH LOCATION ‘instruction’ 

FINISH LOCATION LOC001 

FINISH LOCATION LOC001 
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4.5 MONITORING TIME SPENT OVER MULTIPLE LOCATIONS 
This facility provides a measure of the time spent on an overall job or task which involves visiting 
multiple locations.  
 

In this case the operator will scan a ‘Group Start’ barcode at the commencement of the task and a 
‘Group Finish’ barcode when the task is completed. Between the Group Start and Group Finish bar-
codes the operator will proceed as normal to scan Location Codes, Status codes etc. as required in 
order to monitor the activity itself. 
 

To use the Group Start and Group Finish facility create a Location in the Locations database to act 
as the Start and Finish Location for the Activity being monitored.  This location could be a physical 
location (eg: the Security Guard office from which security patrols will start and finish),  or a ‘logical 
Location representing Activity Start/ Finish, Shift Start/ Finish etc. 
 

Multiple Group Start/ Finish Locations may be created as required. 
 

In order for the system to recognise the Group Start and finish ‘instructions’ the Group Start and Fin-
ish barcodes will include the relevant Location code from the Locations database with a leading / or $ 
character as follows: 

START XYZ ACTIVITY 
STOP XYZ ACTIVITY 
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5.0 GENERATING THE BARCODES 
OPN_SLM includes a barcode label printing module as standard which operates with the desktop 
Toshiba B-EV4T label printer. 
 

This standard module generates 70mm x 32mm self-adhesive paper or polyester labels and where 
necessary will automatically include the relevant formatting characters as summarised in section 3.0 
above, depending on the type of barcode label being printed. 
 

If preferred however barcodes may be generated externally from OPN_SLM, however in this case it 
will be necessary to ensure the barcodes are printed according to the correct data format (ie: includ-
ing the leading identifier character where appropriate) 
 
5.1 PRINTING BARCODE LABELS FROM OPN_SLM 
To print barcoded location labels click Tools > Barcode printing and proceed as shown below: 

1. Configure the format of the Location Labels. Use the relevant 
drop down list to select up to 4 lines of data from the Locations                     
database for the labels. Once configured this format will remain as 
default until subsequently changed. 
 

In this example the labels will include the Location code (as                   
barcode), the location code (as text) plus the Location Description 
and customer name (as text). 

2. Use the search facility to display a specific Location code as 
required, or use the * wild card to display all Locations. 
 

Highlight the Location(s) to be printed, or click the Select All 
box to print all Locations. 

3. Use the drop down list to select the type of location barcodes required. ie: simple 
Location barcodes only, or Location Start and Finish label pairs, or Group Start and 
Finish label pairs. Note that the relevant formatting characters will automatically be 
included when the barcodes are printed. 

4. Specify the no. of copies required 
and click Print to generate the labels 

Note: The label printing option works with the B-EV4T               
thermal label printer using 70mm x 32mm paper or 
polyester labels 
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6.0 DOWNLOADING THE OPN2001 DATA COLLECTOR 
In use the OPN2001 data collector will be used to monitor service levels by scanning location                    
barcodes.  
To download the stored barcode data from the data collector proceed as shown below. 
 

Note: The Transfer Data facility will automatically synchronise the OPN2001 real-time clock. Before 
using the data collectors we therefore recommend using the Transfer Data function to ensure the all 
the devices are synchronised and set to the correct time 

2. If required set the system to ‘Ask for a reference before each 
download’ and connect the OPN2001 to a suitable USB port on the 
PC. 
 

The optional download Reference may be used to select data when 
reporting 

1. Click Transfer Data 

3. OPN_SLM connects to the data collector 
and downloads stored data. 
The real-time clock in the data collector will 
also be synchronised to the PC clock. 

4. Enter a download reference (if enabled). 

5. Download successful. Click OK 

6. The OPN2001 may be disconnected.                                                                            
Note: stored data will automatically be cleared from 
the OPN2001 after a successful download. 
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6.1 EDITING THE DOWNLOADED TRANSACTIONS 
The data downloaded from the OPN2001 data collectors will be written to the Transactions database 
for reporting and/ or exporting. 
These data may also be manually edited if required. Existing transactions may be edited or                   
deleted and new transactions manually entered as required. 
 

The following data is stored for each transaction: 
• Reference. Optional. This allows a Reference code to be attached to the transaction which 

may be used when reporting. (this is the Download reference that can be entered when 
downloading the data collectors (see Section 6.0 above). 

• Operator ID. Optional. This is the ID of the operator using the OPN2001.  
• Serial No. Optional. This is the serial no. of the OPN2001 used to perform the transaction  
• Location Code. Mandatory. This is the Location visited 
• Status Code. Optional. This allows a status code or ‘observation’ to be attached to the trans-

action. Note: If multiple Status Codes are to be logged against the Location then multiple 
transactions will be stored in the transactions database 

• Start Date/Time. Mandatory. This is the date/ time at which the Location code was scanned 
on arrival at the Location 

• Stop Date/ Time. Optional. Used only where the time spent at the location is being monitored 
and represents the time when the activity was finished at that location. 

• Elapsed time (automatically calculated) 
 
 

To manually add a transaction or to edit and existing transaction click Edit > Transactions from the 
program menu and proceed as shown below: 

Highlight a single transaction and click Edit to amend, or highlight one 
or more records and click Delete to remove those records from the    
database. 
 

Alternatively click Add New to manually enter a new transaction. 
 

Note: To order the Edit Transactions grid by any specific data field click 
on the relevant field header. 

Data collector not allocated to specific 
operator and no Operator code 
scanned. Operator therefore blank  

Multiple Status Codes scanned against 
Location 1004. Shown in ’raw’ transac-
tions database as separate records  

Locations where simple attendance 
scanning is required (no finish time) 
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7.0 EXPORTING THE TRANSACTIONS 
The stored transactions may be exported from the OPN_SLM in text or Excel format. 
To edit the transactions click File > Export > Transactions from the program menu and proceed as 
follows: 

1. Select the date range to be exported 
if required and click OK 

2. Specify the location, name and file 
type for the exported data file and click 
Save to generate the file. 
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8.0 REPORTING 
A selection of standard reports are incorporated into the system. To run reports proceed as follows: 

1. Click Reports 

2. Select the report type required from the 
list, and selection criteria for the data. Click 
Run Report to generate the report  

3. The report is generated. 
Note: Any data records which have been manually entered or 
edited (see section 6.1 below) will be highlighted with an aster-
isk in the left hand column. 

8.1 AVAILABLE REPORTS 
Standard Reports include: 
 

 GENERAL REPORTS 

• List Operators. Lists all operators in the Operators database for the selection criteria entered 
 

• List Locations. Lists all locations in the Locations database for the selection criteria entered 

 
 SCANNED DATA REPORTS 
• Scanned Locations (by Operator). Shows the scanned locations for all data in the selection 

criteria entered (ie: shows operators in the selected Group for whom no activity was found). 
 

• Scanned Locations (by Location). Shows the scanned locations for all data in the selection 
criteria entered (ie: shows locations in the selected Group for which no transactions were 
found).  

 

• Scanned Locations (by Route). Shows the scanned locations for all data/Routes in the se-
lection criteria entered (ie: shows locations in the selected Group for which no transactions 
were found).  

 

• Elapsed Time (by Operator). Shows the locations scanned for all dates and for all operators 
in the selection criteria. This report includes operators in the selected group for whom no activ-
ity was logged. 

 

• Elapsed Time (By Location). Shows all activities for all data in the selection criteria. Includes 
Locations in the selected group for which no transactions were found  

 

• Raw Transactions. Shows a chronological list of all transactions in the selected  

 
 ATTENDANCE REPORT 
• Attendance (By Route). Shows all activities for all data in the selection criteria. Includes loca-

tions in the selected Routes for which no transactions were found and inserts an entry for 
every day in the selected date range, including days for which no transactions are found. 
(Note: if a large date range is selected this report may take an extended period to process and 
will generate a report many pages long) 
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APPENDIX A  IMPORT FILE DATA FORMATS 
 

The OPN_SLM system databases may be initialised by importing data from simple csv files in the 
formats outlined below. 
 

Note that importing a datafile will overwrite any existing data in the database. ie: the database will be 
completely refreshed. 

A.1 OPERATORS DATA FILE  
The Operators data file must contain data records in csv format as follows 
 

 <Operator ID>,<Operator Name>,<Team Name>,<OPN2001 Serial No><CR><[LF> 
 

Where <CR><LF> are the carriage return and line feed characters. 
 

Example import file format: 
 

A1001,Lilley Yates 
B1002,Peter Offley,TEAM-5 
B1004,Rupert Randolph,GUARD-IT,026288 
AB00078,Norman Bates,,343242 
 

Note: only the Operator ID is mandatory. 
 
 
A.2 LOCATIONS DATA FILE 
The Locations data file must contain data records in csv format as follows 
 

<Loc’n ID>,<Description>,<Add. Field 1>,<Add. Field 2>,<Add. Field 3>,<Add. Field 4><CR><[LF> 
 

Where <CR><LF> are the carriage return and line feed characters. 
 

Example import file format: 
 

LOC002,Main Gate 
LOC002,Reception,Block 7,Building A, Gnd Floor 
LOC99, Director’s Suite, Block 1, Buliding 1, 7th Floor 
SITEB1004,Perimeter fence,,,, Section A, 
 

Note: only the Location ID is mandatory. 
 
 
A.3 ROUTES DATA FILE 
The Routes data file must contain data records in csv format as follows 
 

            <Route ID>,<Description>,<Location 1>,<Location 2>,< Location 3>,P.<CR><[LF> 
 

Where  
<Location 1>,<Location 2> etc. are the location codes of the Locations to be included in this route 
and  
<CR><LF> are the carriage return and line feed characters. 
 

Example import file format: 
 

R2,Exterior Main building, LOC001, LOC002, LOC49,LOC55,LOC72 
R3,Block A, LOC006,LOC007,LOC008,LOC009,LOC201,LOC202,LOC203 
R77,Research and Development, LOC006,LOC007,LOC015,LOC106,LOC23 
 

Note: only the Route ID is mandatory 
 
 
A.4 STATUS CODES DATA FILE 
The Status codes data file must contain data records in csv format as follows 
 

                                     <Status Code>,<Description<CR><[LF> 
 

Where <CR><LF> are the carriage return and line feed characters. 
 

Example import file format: 
 

S001,Spillage 
S002,Faulty Lighting 
S004,Broken Window 
 

Note: only the Status Code is mandatory 


